Help!!!! TMI pics

Bleeding months after surgery

Discuss any questions, problems or share your solutions here...

Return to General Anal Fissure Discussion




Help!!!! TMI pics

Postby Lovingmex3 » 21 Aug 2017, 18:19

I had surgery and all went well. I've healed from it and have no more pain. It's been more than 5 months since and sometimes when I go #2 there is a tiny bit of blood when I wipe, but no pain. Yesterday i noticed I have been bleeding a lot from my anus even when I'm not having a bowel movement.. when I'm urinating! . There is absolutely no pain. TMI i thought I was on my period when I wiped. The blood drips in the toilet when i am urinating! And it is infact coming from my anus. I wiped and there is clots. I dont know if my inscision came open? It should of been healed by now and i did have surgery 2 weeks ago for something unrelated and was conspated from the pain pills. I am going to the doctor tomorrow and ill keep you guys updated.
Attachments
IMG_2698.JPG
IMG_2694.JPG
Lovingmex3
Newbie
 
Posts: 3
Topics: 2
Joined: 21 Aug 2017, 18:07
Has thanked: 0 time
Been thanked: 0 time
Gender: None specified

Re: Help!!!! TMI pics

Postby yenrac » 07 Nov 2017, 22:15

Just curious, did you figure out what was going on?
yenrac
Fibre Addict
 
Posts: 19
Joined: 18 Sep 2017, 15:32
Has thanked: 0 time
Been thanked: 0 time
Gender: None specified


  • Similar Topics
    Replies
    Views
    Last post

Return to General Anal Fissure Discussion



Who is online

Users browsing this forum: Bing [Bot] and 0 guests